FDP Forum / Noisy rectifier tube?/ 6 messages in thread.

1 to 6 of 6 shown.


Mars Hall



USA NW Indiana

Telefunkin'
Dec 26th, 2017 07:08 AM        

A Sylvania "made in Britain" GZ34 makes a fizz or buzzy noise when operating, as if internal components are vibrating. Is this an indication the tube may be starting to go bad? The bias and plate voltage stay consistent. I replaced to tube, just in case.



rfrakes331K

Contributing Member
*******

IL USA

RonHalen Jokingly He Says
Dec 26th, 2017 07:17 AM        

Does the new Rectifier do the same thing?



Mars Hall



USA NW Indiana

Telefunkin'
Dec 26th, 2017 07:22 AM        

No it does not.



slider313



NC

Dec 27th, 2017 07:31 PM        

It may have to do with a components "mis-alignment" and was probably doing that since it was new. If it's mine, I toss it. Yeah, I know it's a Sylvania/Mullard but it won't serve any purpose if you save it.



Doc Sarvis

Contributing Member
**********
**********
**

USA/Salt Lake City

Tuned Strings and Tight Lines
Jan 3rd, 2018 07:47 PM        

You could try tube dampers. I use them on a couple of tubes in my older Victoria Sovereign. Both the EF86 and 6BM8 have oscillation issues that resolve with dampers. I always have extras on hand. This is of course if the tube tests "good".



Mars Hall



USA NW Indiana

Telefunkin'
Jan 4th, 2018 03:47 AM        

As t turned out, the tube ended up failing. Thank you all.



Copyright 1999-2003 Fender Discussion Page, LLC. Visit the web site at http://www.fenderforum.com