FDP Home Page / FDP Forum / FAQ's

The FDP is made possible by the following companies and individual members like you.
Please use the links below to show them we value their sponsorship.

Jensen Loudspeakers

Yellowjackets Tube Converters

WD Music

Amplified Parts

Antique Electronics Supply

Apex Tube Matching

Guitar Center

Sweetwater

Amazon

Musician's Friend

MOD KITS DIY


* God bless America and our men and women in uniform *

* Illegitimi non carborundum! *

If you benefit and learn from the FDP and enjoy our site, please help support us and become a Contributing Member or make a Donation today! The FDP counts on YOU to help keep the site going with an annual contribution. It's quick and easy with PayPal. Please do it TODAY!

Chris Greene, Host & Founder

LOST YOUR PASSWORD?

......................................................................

   
FDP Jam
Calendar
Find musicians
in your area!
  Search the Forums  

FDP Forum / Fender Amps: Vintage (before 1985) / Help ! 1966 Super Reverb Problem

HKC

Denmark

Sep 18th, 2017 06:23 AM   Edit   Profile   Print Topic   Search Topic

Hi there
I have a pretty annoying problem with my Super Reverb.
The bass changes during performances. Actually it may be more than just the bass but it simply sounds like someone plugged in a low pass filter. It is quite easy to hear but since it's quite unpredictable it is not easy to fix. I have only experienced it on channel two.
What can this be. The amp has just spend a couple of weeks at the amp doctor but he only experienced it once and he couldn't reproduce it and therefore couldn't fix it.

All the best
Henrik Krogh

JJuran
Contributing Member
******

Boston Area

Sep 20th, 2017 10:04 PM   Edit   Profile   Print Topic   Search Topic

Hi Henrik -

Your symptom description suggests that the root cause is an intermittent connection somewhere on the cooler side of the amp that channel two works from.

I think your tech gave up too soon and you might do well to find another.

Couple of ideas ...

1 - Have your amp doctor check out the condition of all the potentiometers. One of our control pots may be starting to fail. While he's in there, he can easily re-flow solder joints at the lugs of those control pots. You may have an intermittent connection failure at one or more of the control potentiometer(s) in channel two.

2 - Have your amp tech visually examine and re-flow (as needed) connections on the circuit board. Chop sticks can be very handy here to isolate a loose or cold-solder connection.

Good luck



KnowledgeSeeker

USA

Measure twice. Cut once
Oct 10th, 2017 10:06 AM   Edit   Profile   Print Topic   Search Topic

also check the solder joints on the tone stack for the bass on Vib channel. Make sure its only on the Vib and not both channels too. This will help isolate the possible cause.

FDP Forum / Fender Amps: Vintage (before 1985) / Help ! 1966 Super Reverb Problem




Reply to this Topic
Display my email address             Lost your password?
Your Message:
Link Address (URL):
Link Title:




Moderators: Chris Greene  Iron Man  reverendrob  

FDP, LLC Privacy Policy: Your real name, username, and email
are held in confidence and not disclosed to any third parties, sold, or
used for anything other than FDP Forum registration unless you specifically authorize disclosure.

Furtkamp.com 
Internet Application Development

Copyright © 1999-2017 Fender Discussion Page, LLC   All Rights Reserved