FDP Home Page / FDP Forum / FAQ's

The FDP is made possible by the following companies and individual members like you.
Please use the links below to show them we value their sponsorship.

Antique Electronics Supply

Sweetwater

Jensen Loudspeakers

Musician's Friend

Apex Tube Matching

Yellowjackets Tube Converters

Amazon

WD Music

Amplified Parts

MOD KITS DIY

Guitar Center


* God bless America and our men and women in uniform *

* Illegitimi non carborundum! *

If you benefit and learn from the FDP and enjoy our site, please help support us and become a Contributing Member or make a Donation today! The FDP counts on YOU to help keep the site going with an annual contribution. It's quick and easy with PayPal. Please do it TODAY!

Chris Greene, Host & Founder

LOST YOUR PASSWORD?

......................................................................

   
FDP Jam
Calendar
Find musicians
in your area!
  Search the Forums  

FDP Forum / Miscellaneous and Non-Fender Topics / BOSS Pedal Problems

macguy

USA

May 29th, 2017 10:25 AM   Edit   Profile   Print Topic   Search Topic

My Boss DD-6...the MODE knob selection does not function properly: a selected setting, the effect, will, after several minutes, seem to drift to the next setting's effect. If I rotate the knob back and forth a few times, sometimes the selected setting is restored, but not always. Then, after leaving the pedal on the correct setting will return...sometimes for over an hour. I had this issue a couple of years ago, sent the pedal to BOSS and for a "diagnostic fee" plus a repair fee they fixed it. But alas, the issue has returned.
Anyone have a suggestion??? Maybe this is an excuse to buy a MXR Carbon Copy...

Thanks,
MG

(This message was last edited by macguy at 04:24 PM, May 29th, 2017)

Mick Reid
Contributing Member
***

Australia

American-made in Oz!!
May 29th, 2017 04:00 PM   Edit   Profile   Print Topic   Search Topic

If the same issue has occurred twice*after* a mfr repair, I'd move on, but that's just me.

There is no shortage of delay options out there nowadays. It all depends on you needs & budget.

As for the MXR CC, it's a great analogue delay imo. I have one on my board, but if you're looking for the 5200ms of the DD-6, you won't get it. The CC is only 600ms.
It works for me since I'm a 4-6 repeats guy or bit of slapback. Does those beautifully.

There was a discussion here recently on Digital Delays if it's digi you want.

Internal link

ejm

usa

May 30th, 2017 08:48 AM   Edit   Profile   Print Topic   Search Topic

Try cleaning the offending knob/switch with contact cleaner.

I have an old Lexicon LXP-1 reverb/processor that had a similar problem. It would "lose lock" on a setting and go into an "unlocked" mode. It was totally at random and intermittent. I'd "reset" it and it would work fine for maybe hours, maybe minutes.

Not having any better ideas, I recently sprayed the rotary switches with contact cleaner. That was a month or so ago, I have been using it a lot, and no hiccups so far.

Be sure to use the right kind of cleaner. I think the "right" kind is one that is marked safe for plastics.


macguy

USA

May 30th, 2017 02:39 PM   Edit   Profile   Print Topic   Search Topic

I will give the cleaning routine a try...

Thanks to one and all for the input.

MG


reverendrob
FDP Data Goon
Moderator

We all want

our time in hell
May 30th, 2017 04:40 PM   Edit   Profile   Print Topic   Search Topic

Yea, the contact cleaner is the way to go. I'm partial to the Deoxit Faderlube for most guitar stuff.

It has not been a problem with any pedal, including Boss ones, I've used it on.

macguy

USA

May 31st, 2017 11:38 AM   Edit   Profile   Print Topic   Search Topic

Thanks Rev,

It looks like cleaner is the final option prior to...scrap.

MG

reverendrob
FDP Data Goon
Moderator

We all want

our time in hell
May 31st, 2017 04:14 PM   Edit   Profile   Print Topic   Search Topic

I'd contact Roland/Boss again if that doesn't fix it as well, "I had it repaired and it's back the same" and see what they say.

Steve Dallman
Contributing Member
**********

Merrill, Wisconsin

Age is just a number...mine is big
Jun 9th, 2017 07:12 AM   Edit   Profile   Print Topic   Search Topic

All of what the good Rev said. Contact Boss, try the cleaner, faderlube is the best, etc. At least find out what Boss did the first fix.

I bought a Peavey Vypyr cheap at a pawn shop. EVERY knob but the master jumped all over the place. A little lube in each control (they are rotary encoders, probably like in your pedal) and the amp works fine.

Leftee
Contributing Member
*****

VA

Jun 9th, 2017 01:19 PM   Edit   Profile   Print Topic   Search Topic

Good to know that about the Vypyr. Mine is starting to do that. I've got a can of Caig deoxit somewhere.

FDP Forum / Miscellaneous and Non-Fender Topics / BOSS Pedal Problems




Reply to this Topic
Display my email address             Lost your password?
Your Message:
Link Address (URL):
Link Title:




Moderators: Chris Greene  Iron Man  reverendrob  

FDP, LLC Privacy Policy: Your real name, username, and email
are held in confidence and not disclosed to any third parties, sold, or
used for anything other than FDP Forum registration unless you specifically authorize disclosure.

Furtkamp.com 
Internet Application Development

Copyright © 1999-2017 Fender Discussion Page, LLC   All Rights Reserved