FDP Home Page / FDP Forum / FAQ's

The FDP is made possible by the following companies and individual members like you.
Please use the links below to show them we value their sponsorship.

Guitar Center

Apex Tube Matching

Amazon

Yellowjackets Tube Converters

Amplified Parts

WD Music

Antique Electronics Supply

Musician's Friend

Sweetwater

Jensen Loudspeakers

MOD KITS DIY


* God bless America and our men and women in uniform *

* Illegitimi non carborundum! *

If you benefit and learn from the FDP and enjoy our site, please help support us and become a Contributing Member or make a Donation today! The FDP counts on YOU to help keep the site going with an annual contribution. It's quick and easy with PayPal. Please do it TODAY!

Chris Greene, Host & Founder

LOST YOUR PASSWORD?

......................................................................

   
FDP Jam
Calendar
Find musicians
in your area!
  Search the Forums  

FDP Forum / Amp Mods, Repairs, and Projects / Champion 110 reverb grounding

Dadzmad

USA

Feb 11th, 2017 09:35 AM   Edit   Profile   Print Topic   Search Topic

I posted this elsewhere and got no replys so I'll try here

I am planning on replacing the factory reverb unit on a Fender Champion 110 and need to run my understanding of the reverb grounding past someone who knows how this works to make sure I am going in the right direction.

The amp schematic shows the reverb has two wires for input (green & black) and two for output (red & black) I assume the black is ground for both in and out. These are wired to the reverb and connect to the board with clips.

From what I've read in the forums a MOD 8BB2A1B unit will work as a replacement. It’s got “input grounded/output grounded” and connects to RCA plugs. I plan to cut in a pair of RCA plugs into the existing wires. The new RCA’s with Input green to center / black to outer ring and output red to center and black to outer ring. Does this sound right?

The replacement unit is horizontal mount with open side down mounting plane which seems right.

I got this amp in an equipment swap back when I had teenage boys lurking in my garage. Last spring I put a WGS Veteran in it and was surprised by how good it can sound, now I've got an urge for a $20 reverb upgrade.

Peegoo
Contributing Member
**********
**********
******

The spotlight

looks like a prison break
Feb 12th, 2017 11:09 AM   Edit   Profile   Print Topic   Search Topic

The chassis has a 'send' (sends signal to the reverb pan's input jack) and a 'return' (brings signal back to the chassis from the reverb pan's output jack).

I don't see color codes on the schematic--see link below--but your assumption (black = ground) is safe, even if it's not correct.

You won't fry anything if you get the polarity the wrong way 'round because the tank itself does not share a common ground with the chassis. The tank is grounded to the chassis via the leads.

You can test the tank's connections for continuity to ground by using a meter across the input and pan, and output and pan. That's how I'd approach it.

Click

Dadzmad

USA

Feb 12th, 2017 01:03 PM   Edit   Profile   Print Topic   Search Topic

Thanks Peegoo

Dadzmad

USA

Apr 1st, 2017 03:49 PM   Edit   Profile   Print Topic   Search Topic

I forgot to post that the mod works well. I guessed right the green is in red is out and the blacks are ground. The reverb upgrade was well worth the $20. I'm going to call this one my "Schwinn Reverb"

(This message was last edited by Dadzmad at 08:51 PM, Apr 1st, 2017)

pdf64

UK

Apr 2nd, 2017 04:03 AM   Edit   Profile   Print Topic   Search Topic

Obviously if it works, it works!
Given that, I think there must be a difference between the Accutronics version of 'input grounded/output grounded' and the Mod version.
Because as I see it, from the schematic, if the outers of the in and out RCAs were connected directly together, the drive circuit would go crazy.
The circuit requires that the outers of the 2 RCAs are isolated from each other.
The may occur with the Mod, as, unlike Accutronics, the body shell doesn't seem to be plated metal (ie conductive).
Could you check that with a meter? ie unplug the tank and check the resistance between the in and out RCA outers.

Dadzmad

USA

Apr 2nd, 2017 08:13 AM   Edit   Profile   Print Topic   Search Topic

You know pdf64 - I think you have explained what was going on. My meter has been borrowed so I'm guessing my ID is probably reversed. The Fender schematic ID'd the OUT pair as red out and the IN pair as black in. So when I first hooked it up I had the RCAs with the IN being black center and green outer, and with the Out being red center and black outer. This gave me a huge whine when powered up.Yesterday I reversed the two wires on the IN side and all is well.

So for posterity of web searches - forget my rambling about the wiring order and lets leave it at - this model of reverb works well with the Champion 110

FDP Forum / Amp Mods, Repairs, and Projects / Champion 110 reverb grounding




Reply to this Topic
Display my email address             Lost your password?
Your Message:
Link Address (URL):
Link Title:




Moderators: Chris Greene  Iron Man  reverendrob  

FDP, LLC Privacy Policy: Your real name, username, and email
are held in confidence and not disclosed to any third parties, sold, or
used for anything other than FDP Forum registration unless you specifically authorize disclosure.

Furtkamp.com 
Internet Application Development

Copyright © 1999-2017 Fender Discussion Page, LLC   All Rights Reserved