FDP Home Page / FDP Forum / FAQ's

The FDP is made possible by the following companies and individual members like you.
Please use the links below to show them we value their sponsorship.

Amplified Parts

Musician's Friend

Amazon

Guitar Center

Apex Tube Matching

MOD KITS DIY

WD Music

Antique Electronics Supply

Jensen Loudspeakers

Yellowjackets Tube Converters

Sweetwater


* God bless America and our men and women in uniform *

* Illegitimi non carborundum! *

If you benefit and learn from the FDP and enjoy our site, please help support us and become a Contributing Member or make a Donation today! The FDP counts on YOU to help keep the site going with an annual contribution. It's quick and easy with PayPal. Please do it TODAY!

Chris Greene, Host & Founder

LOST YOUR PASSWORD?

......................................................................

   
FDP Jam
Calendar
Find musicians
in your area!
  Search the Forums  

FDP Forum / Amp Mods, Repairs, and Projects / I think I hosed my amp.....

Guitar Fool
Contributing Member
**********
********

Sunshine State

Just a pawn in someone else's game
Jan 2nd, 2017 01:20 PM   Edit   Profile   Print Topic   Search Topic

after it warms up I get the dreaded crackling/popping at zero volume....10 maybe 15 minutes

thoughts?

willie
Contributing Member
*******

Too Near Atlanta GA

Amp Tech Emeritus
Jan 2nd, 2017 01:29 PM   Edit   Profile   Print Topic   Search Topic

What type of amp? Not always that bad..

w

Guitar Fool
Contributing Member
**********
********

Sunshine State

Just a pawn in someone else's game
Jan 2nd, 2017 02:18 PM   Edit   Profile   Print Topic   Search Topic

1958 Gibson GA-20...it was fine when I got it... it had been awhile since it's last service ... I planned on having it done anyway...but just curious as to what causes this sort of thing...I don't think its the pots.....and I've swapped the tubes out.....

it sounds awesome when its dimed..... maybe that's what happened...;-0

I'm just guessing capacitors

Guitar Fool
Contributing Member
**********
********

Sunshine State

Just a pawn in someone else's game
Jan 2nd, 2017 02:19 PM   Edit   Profile   Print Topic   Search Topic

I've got it on now...vol at zero.... no cables plugged in and its got a noticeable erratic hissing sound... the popping and the crackling hasn't started yet...

Elmo66
Contributing Member
*********

Midwest USA

Jan 2nd, 2017 02:46 PM   Edit   Profile   Print Topic   Search Topic

Sure sounds like bad plate load resistors to me.

willie
Contributing Member
*******

Too Near Atlanta GA

Amp Tech Emeritus
Jan 2nd, 2017 05:02 PM   Edit   Profile   Print Topic   Search Topic

Could well be caps...have you visually inspected them? Even if they look okay, you might still have cap issues. When were they last changed?

Another issue could be carbon traces on the tube sockets...a bit more uncommon though.

w

Guitar Fool
Contributing Member
**********
********

Sunshine State

Just a pawn in someone else's game
Jan 2nd, 2017 06:13 PM   Edit   Profile   Print Topic   Search Topic

I can clean and re tension tube sockets...the caps look ok to me but I'm not that amp savvy....the only 2 that look to have been replaced are the 2 big ones...... I can remember to take a picture tomorrow, I will and then post...

thanks for the help guys

pdf64

UK

Jan 3rd, 2017 02:16 AM   Edit   Profile   Print Topic   Search Topic

With a 50s amp, pretty much any of the remaining original caps or resistors can go bad at any time.
If reliability is paramount I suggest to replace them all.
Unfortunately even the bumble bee coupling caps tend to leak dc, causing big problems.
If you just want to fix this issue it should be a quick simple fix for a tech to identify and replace the culprit.
So hopefully it's not a big deal if it's not a bad tube or tube socket contact.

willie
Contributing Member
*******

Too Near Atlanta GA

Amp Tech Emeritus
Jan 3rd, 2017 07:48 AM   Edit   Profile   Print Topic   Search Topic

Completely concur with pdf64...

w

FDP Forum / Amp Mods, Repairs, and Projects / I think I hosed my amp.....




Reply to this Topic
Display my email address             Lost your password?
Your Message:
Link Address (URL):
Link Title:




Moderators: Chris Greene  Iron Man  reverendrob  

FDP, LLC Privacy Policy: Your real name, username, and email
are held in confidence and not disclosed to any third parties, sold, or
used for anything other than FDP Forum registration unless you specifically authorize disclosure.

Furtkamp.com 
Internet Application Development

Copyright © 1999-2017 Fender Discussion Page, LLC   All Rights Reserved