FDP Home Page / FDP Forum / FAQ's

The FDP is made possible by the following companies and individual members like you.
Please use the links below to show them we value their sponsorship.

WD Music

MOD KITS DIY

Apex Tube Matching

Antique Electronics Supply

Guitar Center

Amplified Parts

Jensen Loudspeakers

Sweetwater

Yellowjackets Tube Converters

Musician's Friend

Amazon


* God bless America and our men and women in uniform *

* Illegitimi non carborundum! *

If you benefit and learn from the FDP and enjoy our site, please help support us and become a Contributing Member or make a Donation today! The FDP counts on YOU to help keep the site going with an annual contribution. It's quick and easy with PayPal. Please do it TODAY!

Chris Greene, Host & Founder

LOST YOUR PASSWORD?

......................................................................

   
FDP Jam
Calendar
Find musicians
in your area!
  Search the Forums  

FDP Forum / Fender Amps: 1985 - Current / '64 Vibroverb Custom Club

Next 20 Messages   Newest 20 Messages
Peppy

Arizona

Sep 18th, 2004 01:55 PM   Edit   Profile   Print Topic   Search Topic

Don't see one in my search so if not let me start it here. I've had mine about a year...couldn't pass it up for the price. Had some rattling/buzzing problems with it but those seem to be fixed now. Alternate it...Fender-wise that is...with my '65 Super Reverb. (My profile has my equipment listed.) Great amp for my cleaner tones when using my only humbucking-equipped guitar. Anyway, let's hear about these amps...next!

Ricey

US

Sep 22nd, 2004 06:48 AM   Edit   Profile   Print Topic   Search Topic

I tried out a used one at GC, They are asking $1,950 used for it which seems high. Too bad because I really liked it. I was skeptical of the 15" speaker, but the amp had plenty of clean sparkle. I could not really turn it up loud at the time, so I am wondering how it breaks up in the "drive" mode?

Ricey

Peppy

Arizona

Sep 22nd, 2004 11:34 AM   Edit   Profile   Print Topic   Search Topic

I paid $1450 new for mine...know the dealer well though.

Peppy

Arizona

Sep 22nd, 2004 11:34 AM   Edit   Profile   Print Topic   Search Topic

Breaks up decent and is LOUD.

Peppy

Arizona

Sep 27th, 2004 08:31 AM   Edit   Profile   Print Topic   Search Topic

As to the speaker question ("skeptical") it fits perfect with that modded circuitry. A lot of people have wanted to change that particular Eminence to a JBL or similar but I have found over time that that speaker fits the amp fine.

nolda
Contributing Member

canada

Sep 27th, 2004 04:26 PM   Edit   Profile   Print Topic   Search Topic

I picked up cs vibroverb last year...Beautiful..but it seems to hiss quite loudly after three or so on the volume control. I actually don't remember if it hissed loudly when I first bought it. Is this just a characteristic of a tube amp or could there be a problem. Actually the first tube amp I've owned in years. I had been using an Ampeg Olympia 350 watts which was dead quiet but no where near the tone. Doesn't seem to be my effects chain. Any suggestions would be greatly appreciated.

Peppy

Arizona

Sep 27th, 2004 06:47 PM   Edit   Profile   Print Topic   Search Topic

Shouldn't hiss...mine is quiet even when cranked. Checked all the tubes? The Custom Vibrolux supposedly hisses but is the only model I know to do that with some regularity. It should be under warranty of course so if you can get it to a tech.

nolda
Contributing Member

canada

Sep 27th, 2004 07:03 PM   Edit   Profile   Print Topic   Search Topic

Thank you for responding...I'll check the tubes...

Peppy

Arizona

Oct 2nd, 2004 07:58 AM   Edit   Profile   Print Topic   Search Topic

Hiss gone?

nolda
Contributing Member

canada

Oct 3rd, 2004 07:18 PM   Edit   Profile   Print Topic   Search Topic

I may have a ground issue in my house Peppy. I did go back to the store where I bought the Vibroverb, found one on the floor and cranked it without plugging in. It hissed more than mine. I checked my tubes and they seem OK. I'll see if it gets louder over time. My wife hisses too so maybe its me.

Peppy

Arizona

Oct 4th, 2004 11:50 AM   Edit   Profile   Print Topic   Search Topic

Mine rattled...several trips to the tech and somehow it stopped. He has no idea and neither do I...maybe just tightened the right thing. Hiss though should be able to be tracked down a bit easier. Hey, if your wife keeps hissing just turn up the Vibroverb....LOUD is the operative word with them.

nolda
Contributing Member

canada

Oct 4th, 2004 08:47 PM   Edit   Profile   Print Topic   Search Topic

You may be on to something...

Peppy

Tucson

Oct 22nd, 2004 08:50 PM   Edit   Profile   Print Topic   Search Topic

Update. I have been playing this amp more and more (see my profile for what else I have) and it just sounds better each time. I have not yet been able to gig with it (have with most of my other amps) but would love to hear it in the context of a band. Not sure how "cutting" it would be with the 15" and open-back but it would definitely be LOUD enough.

(This message was last edited by Peppy at 08:54 PM, Oct 22nd, 2004)

Peppy

Tucson

Jan 15th, 2005 04:34 AM   Edit   Profile   Print Topic   Search Topic

Bump for the new year.

royandreno
Contributing Member
*

Norway

Practice! Life's too short!
Jan 15th, 2005 11:44 AM   Edit   Profile   Print Topic   Search Topic

I'm here too!!
Love those Fender amps :)

justonwo
Contributing Member
*

USA/Berkeley, CA

Jan 15th, 2005 12:09 PM   Edit   Profile   Print Topic   Search Topic

I have one foot in the door of the Vibroverb Club. Mine is currently sitting in the UPS hub here in Oakland waiting to be delivered on Monday. With any luck, it'll be one Vibroverb and not several pieces of one Vibroverb.

Peppy

Tucson

Jan 15th, 2005 02:34 PM   Edit   Profile   Print Topic   Search Topic

You should enjoy it and hopefully it arrives safe. Was cranking mine yesterday and actually used the bright switch to bring out my humbucking pickups...for single coils not really needed. See what you come up with and let us know.

(This message was last edited by Peppy at 02:35 PM, Jan 15th, 2005)

justonwo
Contributing Member
*

USA/Berkeley, CA

Jan 15th, 2005 09:38 PM   Edit   Profile   Print Topic   Search Topic

I'll definitely be posting comments once I have a chance to crank it up.

justonwo
Contributing Member
*

USA/Berkeley, CA

Jan 16th, 2005 07:22 PM   Edit   Profile   Print Topic   Search Topic

(This message was last edited by justonwo at 12:31 AM, Jan 18th, 2005)

justonwo
Contributing Member
*

USA/Berkeley, CA

Jan 18th, 2005 12:31 AM   Edit   Profile   Print Topic   Search Topic

Okay, I'm in. With the arrival of my minty fresh, "pre-owned" Vibroverb, I'm now officially a part of the club. I played through it briefly tonight just to make sure nothing was damaged in shipping. The only thing I noticed was a distinct rattling noise when I hit some notes on the guitar. It sounded like metal rattling against glass. I tapped each preamp tube with a pencil and heard rattling in all but one of them!

Although it sounded pretty much like what I was hearing while playing through the amp, I find it difficult to believe that that many preamp tubes are bad. Do you normally hear some sort of rattling with healthy 12AX7s or are they really all bad? Incidentally, it's the exact same type of rattling I've experienced in my Rivera. It'd be nice if it was a simple matter of replacing them. Can anyone comment on this?

Next 20 Messages   Newest 20 Messages

FDP Forum / Fender Amps: 1985 - Current / '64 Vibroverb Custom Club




Reply to this Topic
Display my email address             Lost your password?
Your Message:
Link Address (URL):
Link Title:




Moderators: Chris Greene  Iron Man  reverendrob  

FDP, LLC Privacy Policy: Your real name, username, and email
are held in confidence and not disclosed to any third parties, sold, or
used for anything other than FDP Forum registration unless you specifically authorize disclosure.

Furtkamp.com 
Internet Application Development

Copyright © 1999-2017 Fender Discussion Page, LLC   All Rights Reserved